Cant withdraw, Pin doesnt work AGAIN!

Tengamer10Tengamer10 Posts: 10Member ✭✭
>:)

This was happening to me exactly a year ago, and now the problem is back!
I had not changed my same old pin since last year. I was trying to withdraw about 300+USD, and there's definitely funds there. I tried it with the same exact HSBC ATM machine i've been using since last year.
It asked for my PIN. It accepted it. When I key in the actual amount, it then says WRONG PIN! Tried it on the same machine 4x (so I wasted 4 dollars).

I waited 24 hours and tried on another machine, from another bank. This time it's RCBC (bank here in the Philippines), and the same exact problem! Exactly the same! Machine accepts my PIN initially. When I key in the amount (this time lesser amount), it again prints "Wrong PIN"! (Wasted another $1)

This is not an insufficient funds problem. The ATM machines will directly say it, if that's the case.

I already email support about it, but I don't want your bug to remain! Support will probably just send me a link to reset password, which will TEMPORARILY solve the problem, only to return again in the future!

Can someone explain to me what's going on exactly?
I can purchase online and offline without problems. Its only during withdrawal this problem comes up.

I always choose Current or Checking in the machine, so if you changed it to Savings, let me know.

Thanks.
Sign In or Register to comment.