Payoneer card rejected by website to make a purchase

EwigkeitEwigkeit Member Posts: 1
Hi, I just tried buying something on a website here in Argentina called "Mercado Libre," which is similar to "eBay." I bought something already last week, so I know it worked before. I have more than sufficient funds on my card, and nothing has changed from last week when I bought something else.
Now, it says I should contact my card provider to Authorize the purchase... Why should I do that, and how?
Thanks!

Answers

  • rpkersbergen123rpkersbergen123 Member Posts: 1
    I have the same issue. My card is rejected online since almost 1 year now. I have emailed customer service about 5 times about this.

    The reply i get is "We can't help you with this"

    And they are sending me the standard reply:
    1. Make sure your CVV is correct
    2. Make sure you have sufficient funds.

    Basically a list with basic things, that only very stupid people would not do.

    Fast is, after all this time i still CANNOT pay online anywhere. Not with UBER, not with EXPEDIA, not with Booking.com.

    I have asked customer service several times, why? But NOBODY is replying or they are replying with the standard message + "Sorry we can't help you"

    I just want to know why;
    1. Is there a limitation on my card and how to work around this?
    2. Is it because i'm abroad right now?
    3. Is it because Payoneer is simply not accepted online

    I really need some answers here.
  • cruzdanilocruzdanilo Member Posts: 1
    edited August 2017
    i've just received my card, activated it, even used to buy lunch, but now i can't buy anything online, paypal, uber, airbnb. i've lost a few hours today talking to customer support and they had no solution. i'm kinda freaking out. this old unanswered thread is really terrifying.
  • [Deleted User][Deleted User] Posts: 76 ✭✭
    The user and all related content has been deleted.
Sign In or Register to comment.